MPLS Labs – The provider network

      1 Comment on MPLS Labs – The provider network

So I just got done building the lab topology for my for MPLS studies.  The lab network will look like this…

image

So I decided to stick with just two customers at this point.  I think it will be enough to get the entire MPLS point across but not too many to confuse the points.  I’m fortunate enough to be building the lab on actual hardware however, there were a couple of limitations I had to get around.  All of the routers being used only have two physical interfaces.  That being said, I came up with a layout that used router sub-interfaces and a standard layer 2 switch with VLANs to connect them all together.  You’ll notice as I do the router configurations that I’m using sub-interfaces, but the rest should be pretty standard.

I’m considering the provider network here to be any ‘P’ (Provider) or ‘PE’ (Provider Edge) routers.  The initial build will be configuring IP addresses and setting up OSPF as the routing protocol between all 7 routers.  That being said, there shouldn’t be anything here that’s new to anyone.  The end goal here is to just have a full mesh of P and PE routers.  In the next post, we’ll configure MPLS.

P1
hostname P1
ip routing
ip cef

no ip domain-lookup

line vty 0 15
password cisco
login

interface FastEthernet0/0
no ip address
duplex auto
speed auto
no shut

interface FastEthernet0/0.1
description VLAN 1 Sub interface
encapsulation dot1Q 1
ip address 172.172.172.2 255.255.255.252

interface FastEthernet0/0.2
description VLAN 2 Sub interface
encapsulation dot1Q 2
ip address 172.172.172.6 255.255.255.252
interface FastEthernet0/0.5
description VLAN 5 Sub interface
encapsulation dot1Q 5
ip address 172.172.172.17 255.255.255.252

interface FastEthernet0/0.6
description VLAN 6 Sub interface
encapsulation dot1Q 6
ip address 172.172.172.21 255.255.255.252

int l0
ip address 2.2.2.2 255.255.255.255

router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 172.172.172.2 0.0.0.0 area 0
network 172.172.172.6 0.0.0.0 area 0
network 172.172.172.17 0.0.0.0 area 0
network 172.172.172.21 0.0.0.0 area 0

enable secret cisco

P2
hostname P2
ip routing
ip cef

no ip domain-lookup

line vty 0 15
password cisco
login

interface FastEthernet0/0
no ip address
duplex auto
speed auto
no shut

interface FastEthernet0/0.4
description VLAN 4 Sub interface
encapsulation dot1Q 4
ip address 172.172.172.13 255.255.255.252

interface FastEthernet0/0.6
description VLAN 6 Sub interface
encapsulation dot1Q 6
ip address 172.172.172.22 255.255.255.252

interface FastEthernet0/0.7
description VLAN 7 Sub interface
encapsulation dot1Q 7
ip address 172.172.172.25 255.255.255.252

interface FastEthernet0/0.9
description VLAN 9 Sub interface
encapsulation dot1Q 9
ip address 172.172.172.33 255.255.255.252

interface FastEthernet0/0.11
description VLAN 11 Sub interface
encapsulation dot1Q 11
ip address 172.172.172.42 255.255.255.252

int l0
ip address 5.5.5.5 255.255.255.255

router ospf 1
log-adjacency-changes
router-id 5.5.5.5
network 5.5.5.5 0.0.0.0 area 0
network 172.172.172.13 0.0.0.0 area 0
network 172.172.172.22 0.0.0.0 area 0
network 172.172.172.25 0.0.0.0 area 0
network 172.172.172.33 0.0.0.0 area 0
network 172.172.172.42 0.0.0.0 area 0

enable secret cisco

P3
hostname P3
ip routing
ip cef

no ip domain-lookup

line vty 0 15
password cisco
login

interface FastEthernet0/0
no ip address
duplex auto
speed auto
no shut
!
interface FastEthernet0/0.8
description VLAN 8 Sub interface
encapsulation dot1Q 8
ip address 172.172.172.30 255.255.255.252

interface FastEthernet0/0.9
description VLAN 9 Sub interface
encapsulation dot1Q 9
ip address 172.172.172.34 255.255.255.252

interface FastEthernet0/0.10
description VLAN 10 Sub interface
encapsulation dot1Q 10
ip address 172.172.172.38 255.255.255.252

int l0
ip address 6.6.6.6 255.255.255.255

router ospf 1
log-adjacency-changes
router-id 6.6.6.6
network 6.6.6.6 0.0.0.0 area 0
network 172.172.172.30 0.0.0.0 area 0
network 172.172.172.34 0.0.0.0 area 0
network 172.172.172.38 0.0.0.0 area 0

enable secret cisco

P4
hostname P4
ip routing
ip cef

no ip domain-lookup

line vty 0 15
password cisco
login

interface FastEthernet0/0
no ip address
duplex auto
speed auto
no shut

interface FastEthernet0/0.3
description VLAN 3 Sub interface
encapsulation dot1Q 3
ip address 172.172.172.10 255.255.255.252

interface FastEthernet0/0.5
description VLAN 5 Sub interface
encapsulation dot1Q 5
ip address 172.172.172.18 255.255.255.252

interface FastEthernet0/0.7
description VLAN 7 Sub interface
encapsulation dot1Q 7
ip address 172.172.172.26 255.255.255.252

interface FastEthernet0/0.8
description VLAN 8 Sub interface
encapsulation dot1Q 8
ip address 172.172.172.29 255.255.255.252

int l0
ip address 4.4.4.4 255.255.255.255

router ospf 1
log-adjacency-changes
router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area 0
network 172.172.172.10 0.0.0.0 area 0
network 172.172.172.18 0.0.0.0 area 0
network 172.172.172.26 0.0.0.0 area 0
network 172.172.172.29 0.0.0.0 area 0

enable secret cisco

PE1
hostname PE1
ip routing
ip cef

no ip domain-lookup

line vty 0 15
password cisco
login

interface FastEthernet0/0
no ip address
duplex auto
speed auto
no shut

interface FastEthernet0/0.1
description VLAN 1 Sub interface
encapsulation dot1Q 1
ip address 172.172.172.1 255.255.255.252

interface FastEthernet0/0.3
description VLAN 3 Sub interface
encapsulation dot1Q 3
ip address 172.172.172.9 255.255.255.252

int l0
ip address 1.1.1.1 255.255.255.255

router ospf 1
log-adjacency-changes
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
network 172.172.172.1 0.0.0.0 area 0
network 172.172.172.9 0.0.0.0 area 0

enable secret cisco

PE2
hostname PE2
ip routing
ip cef

no ip domain-lookup

line vty 0 15
password cisco
login

interface FastEthernet0/0
no ip address
duplex auto
speed auto
no shut
!
interface FastEthernet0/0.2
description VLAN 2 Sub interface
encapsulation dot1Q 2
ip address 172.172.172.5 255.255.255.252

interface FastEthernet0/0.4
description VLAN 4 Sub interface
encapsulation dot1Q 4
ip address 172.172.172.14 255.255.255.252

int l0
ip address 3.3.3.3 255.255.255.255

router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 172.172.172.5 0.0.0.0 area 0
network 172.172.172.14 0.0.0.0 area 0

enable secret cisco

PE3
hostname PE3
ip routing
ip cef

no ip domain-lookup

line vty 0 15
password cisco
login

interface FastEthernet0/0
no ip address
duplex auto
speed auto
no shut
!
interface FastEthernet0/0.10
description VLAN 10 Sub interface
encapsulation dot1Q 10
ip address 172.172.172.37 255.255.255.252

interface FastEthernet0/0.11
description VLAN 11 Sub interface
encapsulation dot1Q 11
ip address 172.172.172.41 255.255.255.252

int l0
ip address 7.7.7.7 255.255.255.255

router ospf 1
log-adjacency-changes
router-id 7.7.7.7
network 7.7.7.7 0.0.0.0 area 0
network 172.172.172.37 0.0.0.0 area 0
network 172.172.172.41 0.0.0.0 area 0

enable secret cisco

Wrap Up

So at this point we should have all of P and PE routers talking OSPF to each other.  you should have full reachability of all of the loopback 0 interfaces between all 7 routers.  Next post, we’ll configure some MPLS.

1 thought on “MPLS Labs – The provider network

  1. litesh gupta

    what routing configuration we need on customer edge routers??

    is it the same as on the providers edge???

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *