You cannot update because WordPress 3.2.1 requires PHP version 5.2.4 or higher. You are running version 5.1.6.

I don’t usually post about the platform I use to host the blog.  However, once in awhile, I fix something on the blog and I think to myself ‘Self – Someone might be having the same issue and you could help them out by writing about it’.  So here we go…

I’m always hesitant about doing updates on the box that I host WordPress on.  For those of you that don’t know, I host my own blog on a old desktop PC that’s sitting on a ledge in my office.  At any rate, I saw that WordPress wanted me to update but when I went to do it I got the error…

“You cannot update because WordPress 3.2.1 requires PHP version 5.2.4 or higher. You are running version 5.1.6.”

I’m not a Linux guru so I looked around to see how to upgrade to a newer version of PHP.  I found that I could update to PHP 5.3 by doing a…

yum install php53

So I tried to do that and yum came back with all kinds of errors about dependencies and just general ‘not working’ types of messages.  I found a blog that mentioned that you had to uninstall the old version of PHP first in order for this to work.  So I ran a…

yum remove php php-cli php-common

Afterwards I ran the php53 install again and it seemed to work.  However when I went to my blog I got a nasty error saying that I didn’t have the SQL package installed for PHP.  So now I’ve thoroughly busted the thing.  After much freaking out I ran this command which saved my life…

yum install php53-mysql

It installed, I restarted Apache and I’m back in business with a cool new admin GUI for WordPress.

1 thought on “You cannot update because WordPress 3.2.1 requires PHP version 5.2.4 or higher. You are running version 5.1.6.

Leave a Reply

Your email address will not be published.